System Outage
Incident Report for Nowsta
Resolved
This incident has been resolved.
Posted Jan 25, 2024 - 20:53 EST
Update
We are continuing to work on a fix for this issue.
Posted Jan 25, 2024 - 17:11 EST
Identified
The Nowsta platform is experiencing an outage, our engineers have located the issue and are currently deploying a fix.
Posted Jan 25, 2024 - 17:11 EST
This incident affected: Scheduling, Time Tracking, and Payroll, Messaging, and 3rd Party Integrations.