System-wide degraded performance
Incident Report for Nowsta
Resolved
We are happy to report that the site-wide performance issues happening yesterday have been fully resolved, and we will be restoring full feature functionality shortly. Please don't hesitate to reach out if you see anything out of the ordinary happening on the platform or any more speed issues.

Thanks again for your patience and understanding. Your continued support and feedback mean everything to us.
Posted Jun 07, 2018 - 10:21 EDT
Update
Hello!

The engineers finished improving the way the application receives and processes employee responses to job requests, which has significantly reduced the burden on the servers. The application appears to be functional and all pages are accessible, albeit operating at a reduced speed.

We found another issue slowing down the application in the time & attendance page. Normally, when you open the time & attendance page, it loads each employees times individually, generating 1000s of requests a minute.

The engineers just released a new update that will significantly reduce the requests needed to generate the same amount of time & attendance information, which should help speed up every account.

As previously stated, click on the Subscribe button to receive the latest information as soon as it's posted. Thank you for your continued patience as we make gradual improvements to the site.
Posted Jun 06, 2018 - 18:40 EDT
Update
Thank you for your patience as we work on resolving the speed issues. Since the last message, we've identified one of the issues being the application would load every client and venue when you first sign on. This does not have much of an effect when a handful of coordinators are online, but definitely compounds when a lot of coordinators are on Nowsta.

The engineering team will be changing this in the future, so the application will load the information only when a coordinator accesses it, which should greatly increase your browsing speed.

We also temporarily removed the dots indicating how many employees are confirmed or being requested in the Event Calendar page, but still display Green events if it's fully confirmed, Yellow if it's not fully confirmed, and Red if an employee has declined a shift. We expect the speed to improve a bit while our engineers take the next step to enhance the app.

The next step to improve your speed is updating the way our application receives and processes employee responses to job requests. Right now, we've estimated this takes up about 23% of our server's resources, so enhancing this aspect of the application should reduce the lag significantly.

As previously stated, we will update you here every hour on the hour with the latest information. If you'd like to receive updates via email, please hit the subscribe button to receive the latest information as soon as it's posted.
Posted Jun 06, 2018 - 16:12 EDT
Update
We are continuing to investigate this issue.
Posted Jun 06, 2018 - 11:26 EDT
Update
The performance degradation issue from yesterday has reoccurred. We're investigating it as quickly as possible, Sorry for any inconvenience.
Posted Jun 05, 2018 - 10:59 EDT
Update
The performance issues have been resolved, all systems are operational.
Posted Jun 04, 2018 - 21:19 EDT
Update
We are continuing to investigate this issue.
Posted Jun 04, 2018 - 18:56 EDT
Investigating
We are currently investigating this issue. Thanks for your patience.
Posted Jun 04, 2018 - 16:00 EDT
This incident affected: Scheduling, Time Tracking, and Payroll and 3rd Party Integrations.