Degraded Service on Coordinator Application & NowstaPay

Incident Report for Nowsta

Resolved

This incident has been resolved.
Posted Aug 15, 2022 - 18:30 EDT

Investigating

We are currently investigating this issue.
Posted Aug 15, 2022 - 18:12 EDT
This incident affected: Scheduling, Time Tracking, and Payroll and Nowstapay.