Nowsta Email Notification feature is experiencing a disruption in service.

Incident Report for Nowsta

Resolved

This incident has been resolved.
Posted Dec 03, 2023 - 12:45 EST

Investigating

The issue is currently being investigated.
Posted Dec 03, 2023 - 12:00 EST