Degraded Performance
Incident Report for Nowsta
Resolved
This incident has been resolved.
Posted Apr 26, 2021 - 14:40 EDT
Update
We are continuing to investigate this issue.
Posted Apr 26, 2021 - 14:30 EDT
Investigating
We are currently investigating the issue.
Posted Apr 26, 2021 - 14:30 EDT
This incident affected: Scheduling, Time Tracking, and Payroll and Messaging.