Temporary payment delays
Incident Report for Nowsta
Resolved
This incident has been resolved, and measures have been put in place to prevent similar delays in the future. Thank you for your patience!
Posted Sep 11, 2018 - 17:00 EDT
Identified
Due to an overwhelming amount of cashouts on NowstaPay in a short timeframe, transaction settlements may be delayed by several hours. All payments will still be submitted before today's ACH cutoff and should be available as scheduled on 9/12. We apologize for any inconvenience.
Posted Sep 11, 2018 - 15:15 EDT
This incident affected: Nowstapay.